CiscoIOS‎ > ‎

Config

Cisco Router Config


To configure vlans on the switches and router do the following:

connect to the Core Router

UNIX> telnet core0

Trying x.x.x.x...
Connected to core0.
Escape character is '^]'.

User Access Verification

Password: <ping>
core0>en                (enable: Like su for superuser)
Password: <pong>

Cisco has tab completion. The shell will recognize the command as long as you have typed enough for it to be distinct. Use '?' for help with specific commands. The following shows the current configuration

core0# sh ru           

look for availiable vlan or next one to use. <Enter> to scroll down <SpaceBar> for page at a time. Any other key will exit the pager.)

Building configuration...
Current configuration : 67041 bytes
!
! Last configuration change at 11:39:23 cdt Mon Sep 19 2005
! NVRAM config last updated at 11:39:38 cdt Mon Sep 19 2005
!
version 12.2
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
no service password-encryption
!
hostname core0
!
enable secret 5 $xxxxxxxxxxxxxxxxxxxxxxxxx/
!
clock timezone cst -6
clock summer-time cdt recurring
ip subnet-zero
ip cef
!
!
ip name-server 66.101.58.4
ip name-server 66.101.58.5
...
--More--

(scroll down to find next availiable vlan. Here, fa0/0.233 is the last used one)
...
!
interface FastEthernet0/0.231
 description mynetwork - 209.144.224.147
 encapsulation dot1Q 231
 ip address 209.144.224.153 255.255.255.248
 ip broadcast-address 0.0.0.0
 no ip redirects
 no ip proxy-arp
 rate-limit input 5000000 24000 24000 conform-action transmit
exceed-action drop
 rate-limit output 5000000 24000 24000 conform-action transmit
exceed-action drop
 no cdp enable
!
interface FastEthernet0/0.232
 description Brookins Consulting - 209.144.224.192-223
 encapsulation dot1Q 232
 ip address 209.144.224.193 255.255.255.224
 ip broadcast-address 0.0.0.0
 no ip redirects
 no ip proxy-arp
 rate-limit input 5000000 24000 24000 conform-action transmit
exceed-action drop
 rate-limit output 5000000 24000 24000 conform-action transmit
exceed-action drop
 no cdp enable
!
interface FastEthernet1/0
 no ip address
 ip broadcast-address 0.0.0.0
 duplex half
!
...
--More--

(use the configs above as a reference when entering the new one)
(much of the config can be simply copied and pasted)

core0# config t  (configure terminal)
Enter configuration commands, one per line.  End with CNTL/Z.
core0(config)#int fa0/0.<new vlan #> (in this case 233 is the next availiable)
core0(config-subif)#interface FastEthernet0/0.<new vlan #> (in this case 233)
core0(config-subif)#description <client description>
core0(config-subif)#encapsulation dot1Q <new vlan #> (in this case 233)

(for the vlan config you have to use 1+<actual network address>)

core0(config-subif)#ip address <network address+1> <netmask>
(ie: if actual network address is 209.144.224.224 use 209.144.224.225 here)

core0(config-subif)#ip broadcast-address 0.0.0.0 
core0(config)#router bgp 23376
core0(config-router)#network <actual network address> mask <netmask>
core0(config-router)#aggregate-address <actual network address> <netmask> summary-only
core0(config-router)#exit
core0(config)#ip route <actual network address> <netmask> Null0 254
core0(config)#^Z
core0#clear ip bgp * soft
core0#copy ru st  (copy running-confing startup-config: save changed info)
Destination filename [startup-config]?
Building configuration...
[OK]
core0# exit

Connect to the Core Switch

UNIX> telnet 10.0.0.100
Trying 10.0.0.100...
Connected to 10.0.0.100.
Escape character is '^]'.


User Access Verification

Password: <ping>
core0.switch>en
Password: <pong>
core0.switch# vlan database
core0.switch(vlan)#vlan <new vlan #> name "<company name or description>"
VLAN <newvlan #> added:
    Name: <company name or description>
core0.switch(vlan)#exit
APPLY completed.
Exiting....
core0.switch#copy ru st
Destination filename [startup-config]?
Building configuration...

core0(config-subif)# no ip redirects
core0(config-subif)# no ip proxy-arp
core0(config-subif)# rate-limit input 5000000 24000 24000
conform-action transmit exceed-action drop
core0(config-subif)# rate-limit output 5000000 24000 24000
conform-action transmit exceed-action drop
core0(config-subif)# no cdp enable
core0(config-subif)#exit
VLAN <newvlan #> added:
    Name: <company name or description>
core0.switch(vlan)#exit
APPLY completed.
Exiting....
core0.switch#copy ru st
Destination filename [startup-config]?
Building configuration...
(now you may wany to check to make sure everything is okay)

core0.switch#sh vlan
core0.switch# exit

Connect to the local switch

(connect the machine to an availiable port and note the port number) (racks: 10.0.0.1<switch#>, cabinets: 10.0.1.1<switch#>)

UNIX> telnet <switch>
Trying 10.0.0.109...       (Using swtich 9 here)
Connected to 10.0.0.109.
Escape character is '^]'.

User Access Verification

Password: <ping>
switch9>en
Password: <pong>
switch9#config t
Enter configuration commands, one per line.  End with CNTL/Z.
switch9(config)#int fa0/<port #>   (interface fastEthernet 0/<port #>)
switch9(config)#description <description>
switch9(config)#switchport access vlan <new vlan #>
switch9(config)#no cdp enable
switch9(config)#^Z
switch9#copy ru st
Destination filename [startup-config]?
Building configuration...
[OK]

(now you may want to look to make sure everything is okay)

switch9#sh ru
switch9#sh int fa0/<port #>
switch9#exit


Comments